Analog Output | Output Channel | 2 channels
 | Output Type | 0 ~ 20 mA 4 ~ 20mA 0 ~ 10V
 | Accuracy | +/- 0.1% of FSR
 | Resolution | +/- 0.02% of FSR
 | Zero Drift | Voltage : +/- 30 uV/ºC Current : +/- 0.2 uA/ºC
 | Span Temperature Coefficient | +/- 25ppm/ºC
 | Programmable Output Slope | Voltage : 0.0625 to 512 V/Second Current : 0.125 to 1024 A/Second
 | Voltage Output Driver | 10mA max (sink/source)
 | Current Load Restistance | 1.Internal power : 500 Ohms max 2.External 24V : 1050 Ohms max
 | Isolation Voltage | 3000Vrms
LED Display | 1 LED as Power/Communication indicator
Power Consumption | Maximum : 1.5W

I-87022 Pin Assignment
Terminal Number | Pin Name
11 | Vout0+
12 | Vout0-
13 | Iout0+
14 | Iout0-
15 | ExtPWR0
16 | Vout1+
17 | Vout1-
18 | Iout1+
19 | Iout1-
20 | ExtPWR1

I-87022 Block Diagram

Voltage Output Wiring | I-87022 Voltage Output Wiring
Current Output Wiring | I-87022 Current Output Wiring
Screw wire into I-87022 | Screw wire into I-87022

I-87022 Dimention

Configuration | Default Setting | Description
Type | 3F | ------------------------------------------
Baudrate | 0A | 115200 bps
Format | 00 | CheckSum disable Immediate Output Engineer Unit Format

Back to Previous Page


Command | Description
%AANNTTCCFF | Set Module Configuration
$AA0N | Perform 4mA calibration for specificed output channel
$AA1N | Perform 20mA calibration for specificed output channel
$AA2 | Read configuration
$AA3NVV | Trim output of specificed channel
$AA4N | Set PowerOn Value of specificed output channel
$AA5 | Read reset status
$AA6N | Readback last output command value of specificed output channel
$AA7N | Perform 10V Calibration for Channel Nl
$AA8N | Readback current output value of specificed output channel
$AA9N | Read DA configuration of specificed output channel
$AA9NTS | Set DA configuration of specificed output channel
$AAF | Read firmware version
$AAM | Read module name
#AAN(Data) | Output analog value of specificed channel
~AA0 | Read module status
~AA1 | Reset module status
~AA2 | Read host watchdog timeout setting
~AA3ETT | Set host watchdog timeout setting
~AA4N | Read Safe Value of specificed output channel
~AA5N | Set Safe Value of specificed output channel
~AAO(Name) | Set module name


Command | %AANNTTCCFF
Description | Set Module Configuration
Syntax %AANNTTCCFF[CHK](cr)
% | a delimiter character
AA | address of setting module (00 to FF)
NN | new address for setting module (00 to FF)
TT | new type for setting module
CC | new baudrate for setting module. It is needed to short INIT* to ground while change baudrate.
FF | new format for setting module. It is needed to short INIT* to ground while change checksum setting.
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command. While change baudrate or checksum setting without short INIT* to ground, the module will return invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | %0102080600
Response | !02
Description | Change address from 01 to 02, return success.
Command | %0202080602
Response | !02
Description | Change data format from 00 to 02, return success.
Reference $AA2
Type Table
Baudrate Table
Format Table
INIT* pin Operation


Command $AA0N
Description I-87022/26 :
Perform 4mA calibration for specificed output channel
I-87024 :
Perform 0mA/-10V calibration for specificed output channel
Syntax $AA0N[CHK](cr)
$ | a delimiter character
AA | address of setting module (00 to FF)
0 | Command for performing calibration For I-87024 : Type = 30, perform 0mA calibration Type = 32, perform -10V calibration.
N | I-87022/26 : specificed channel for calibration (0 to 1) I-87024 : specificed channel for calibration (0 to 3)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $0101
Response | !01
Description | I-87022/26 : Perform 4mA calibation of channel 1 of address 01, response success. I-87024 : Perform 0mA(or -10V) calibation of channel 1 of address 01, response success.
Reference $AA1N


Command $AA1N
Description I-87022/26 :
Perform 20mA calibration for specificed output channel
I-87024 :
Perform 20mA/+10V calibration for specificed output channel
Syntax $AA1N[CHK](cr)
$ | a delimiter character
AA | Address of setting module (00 to FF)
1 | Command for performing calibration For I-87024 : Type = 30, perform 20mA calibration Type = 32, perform +10V calibration.
N | I-87022/26 : Specificed channel for calibration (0 to 1) I-87024 : Specificed channel for calibration (0 to 3)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $0111
Response | !01
Description | I-8722/26 : Perform 20mA calibation of channel 1 of address 01, response success. I-87-24 : Perform 20mA(or +10V) calibation of channel 1 of address 01, response success.
Reference $AA0N


Command | $AA2
Description | Read module configuration
Syntax $AA2[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
2 | command for reading configuration
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AATTCCFF[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
TT | current type setting
CC | current baudrate setting
FF | current format setting
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $012
Response | !01080600
Description | Read configuration of address 01, return success.
Reference %AANNTTCCFF
Type Table
Baudrate Table
Format Table
INIT* pin Operation


Command | $AA3NVV
Description | Trim output of specificed channel
Syntax $AA3NVV[CHK](cr)
$ | a delimiter character
AA | address of setting module (00 to FF)
3 | command for trim output
N | specificed channel for calibration ( for I-87022/26 0 to 1, for I-87024 0to 3 )
VV | trim value, 00 for no change, increase from 01 to 7F(+127), and decrease from FF(-1) to 80(-128) I-87022/26 : Type = 0/1, 4.88 uA each count Type = 2, 2.44m V each count I-87024 : Type = 30/31, 0.3uA each count Type = 32/33/34/35, 0.15mV each count
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01321F
Response | !01
Description | Trim analog output of channel 2 of channel 1 to increase 31 counts, response success.
Reference $AA0N
$AA1N


Command | $AA4N
Description | Set PowerOn Value of specificed output channel
Syntax $AA4N[CHK](cr)
$ | a delimiter character
AA | address of setting module (00 to FF)
4 | command for set PowerOn Value
N | specificed channel for set PowerOn Value( 0-1 for I-87022/26 , 0 to 3 for I-87024 )
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | #012+00.000
Response | >
Description | Set address 01 channel 2 output 0.0, response success. ( for I-87024 )
Command | $0142
Response | !01
Description | Set PowerOn Value of channel 2 of address 01, response success. ( for I-87024 )
Reference #AAN(Data)
$AA7N


Command | $AA5
Description | Read reset status
Syntax $AA5[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
5 | command for read status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AAS[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
S | reset status 1 = the module is been reseted, and the status is reset to 0 after read 0 = the module is not been reseted
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $015
Response | !011
Description | Read reset status of address 1, response the module is reseted before read.
Command | $015
Response | !010
Description | Read reset status of address 1 again, response the module is not reseted before read.
Reference


Command | $AA6N
Description | Readback last output command value of specificed output channel
Syntax $AA6N[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
6 | command for read last output command value
N | I-87022/26 : specificed channel for read last output command value ( 0 to 1 ) I-87024 : specificed channel for read last output command value ( 0 to 3 )
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA(Data)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
(Data) | last output command value
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $0161
Response | !01+05.123
Description | Read the last output command value of channel 1 of address 1, response +05.123.
Reference #AAN(Data)
$AA8N


Command | $AA7N
Description | Perform 10V Calibratioin for Channel of N
Syntax $AA7N[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
7 | command for performing 10V calibration
N | specificed channel to performing 10V calibratioin ( 0 to 1 )
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $0170
Response | !01
Description | Perform 10V calibration of channel 0 of address 01 , response success.
Reference | $AA0N , $AA1N
Modules | I-87022 and I-87026


Command | $AA8N
Description | Readback current output value of specificed output channel
Syntax $AA8N[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
8 | command for read current output value
N | I-87022/26 : specificed channel for read current output value ( 0 to 1 ) I-87024 : specificed channel for read current output value ( 0 to 3 )
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA(Data)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
(Data) | current output value
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $0182
Response | !01+04.500
Description | Read the current output value of channel 2 of address 1, response +04.500. ( for I-87024 )
Reference #AAN(Data)
$AA6N


Command | $AA9N
Description | Readback current output value of specificed output channel
Syntax $AA9N[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
9 | command for read DA configuration of channel N
N | I-87022/26 : specificed channel for read current output value ( 0 to 1 )
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AATS[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
T | analog output type.
S | analog output slewrate.
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $0190
Response | !0110
Description | Read DA configuration of channel 0 of address 01 , return 4 to 20mA output and change imediate.
Reference | $AA9NTS


Command | $AA9NTS
Description | Readback current output value of specificed output channel
Syntax $AA9NTS[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
9 | command for read DA configuration of channel N
N | I-87022/26 : specificed channel for read current output value ( 0 to 1 )
T | analog output type.
S | analog output slewrate.
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $019121
Response | !01
Description | Set DA configuration of channel 1of address 01 : 0 to 10V and slewrate 0.625V/Second, return success..
Reference $AA9N


Command | $AAF
Description | Read firmware version
Syntax $AAF[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
F | command for reading firmware version
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA(Version)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
(Version) | firmware version
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01F
Response | !01B1.0
Description | Read address 01 firmware version, response version is "B1.0".


Command | $AAM
Description | Read module name
Syntax $AAM[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
M | command for reading module name
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA(Name)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
(Name) | module name
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01M
Response | !0187017
Description | Read address 01 module name, response module name is "87017".
Reference ~AAO(Name)


Command | #AAN(Data)
Description | Output analog value of specificed channel
Syntax #AAN(Data)[CHK](cr)
# | a delimiter character
AA | address of output module (00 to FF)
N | channel to output
(Data) | analog output value of specificed channel with the specificed Type Vaule
[CHK] | 2 characters of checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | >[CHK](cr)
Output Overange or Underrange | ?[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Ignore Command | ![CHK](cr)
Syntax error or communication error may get no response.
> | delimiter for valid command
? | delimiter for invalid command or the output value is overrange or underrange. If the channel is not available, the module will response as invalid command.
! | delimiter for ignore command. If host watchdog timeout flag is set, the output command is ignored and the output is SafeValue.
AA | address of response module (00 to FF)
[CHK] | 2 characters of checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | #012+05.000
Response | >
Description | Output analog value +5.0 to channel 2 of address 01, response success. ( for I-87024 )
Reference | Data Format of Analog Output Module


Command | ~AA0
Description | Read module status
Syntax ~AA0[CHK](cr)
~ | a delimiter character
AA | address of reading module (00 to FF)
0 | command for reading module status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AASS[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
SS | module status. The status is stored in the EEPROM of module, and may reset by command ~AA1. 00 = host watchdog status is clear 04 = host watchdog status is set
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~010
Response | !0100
Description | Read module status of address 01, response 00
Reference ~AA1


Command | ~AA1
Description | Reset module status
Syntax ~AA1[CHK](cr)
~ | a delimiter character
AA | address of setting module (00 to FF)
1 | command for reset module status
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~011
Response | !01
Description | Reset module status of address 01, response success
Reference ~AA0


Command | ~AA2
Description | Read host watchdog timeout setting
Syntax ~AA2[CHK](cr)
~ | a delimiter character
AA | address of reading module (00 to FF)
2 | command for reading host watchdog setting
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AAETT[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
E | enable/disable flag. 0 = Host watchdog is disabled 1 = Host watchdog is enabled
TT | host watchdog timeout interval in hexdecimal. 01 is 0.1 second, 02 is 0.2 second and FF is 25.6 seconds.
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~012
Response | !010FF
Description | Read host watchdog setting of address 01, response host watchdog is disabled, and the timeout interval is 25.6 seconds.
Reference ~AA3ETT


Command | ~AA3ETT
Description | Set host watchdog timeout setting
Syntax ~AA3ETT[CHK](cr)
~ | a delimiter character
AA | address of settting module (00 to FF)
3 | command for set host watchdog setting
E | enable/disable flag. 0 = Disable host watchdog 1 = Enable host watchdog
TT | host watchdog timeout interval in hexdecimal. 01 is 0.1 second, 02 is 0.2 second and FF is 25.6 seconds.
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~013164
Response | !01
Description | Set host watchdog setting, enable host, time out interval is 10.0 seconds, to address 01, response success.
Reference ~AA2


Command | ~AA4N
Description | Read Safe Value of specificed output channel
Syntax ~AA4N[CHK](cr)
~ | a delimiter character
AA | address of reading module (00 to FF)
4 | command for read Safe Value
N | specificed channel for read Safe Value
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA(Data)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
(Data) | Safe Value of specificed channel
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~0142
Response | !01+00.000
Description | Read Safe Value of channel 2 of address 01, response Safe Value is +00.000.
Reference ~AA5N


Command | ~AA5N
Description | Set Safe Value of specificed output channel
Syntax ~AA5N[CHK](cr)
~ | a delimiter character
AA | address of setting module (00 to FF)
5 | command for set current output value as Safe Value
N | specificed channel for set Safe Value
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~0152
Response | !01
Description | Set current output value as Safe Value of channel 2 of address 01, response success.
Reference #AAN(Data)
~AA4N


Command | ~AAO(Name)
Description | Set module name
Syntax ~AAO(Name)[CHK](cr)
~ | a delimiter character
AA | address of reading module (00 to FF)
O | command for setting module name
(Name) | module name
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | ~01O87018
Response | !01
Description | Set address 01 module name as "87018", response success.
Reference $AAM


Command | $AA7N
Description | Read PowerOn Value of specificed output channel
Syntax $AA7N[CHK](cr)
$ | a delimiter character
AA | address of reading module (00 to FF)
7 | command for read PowerOn Value
N | specificed channel for read PowerOn Value (0 to 3)
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA(Data)[CHK](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command.
AA | address of response module (00 to FF)
(Data) | PowerOn Value
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $0171
Response | !01+00.000
Description | Read the PowerOn Value of channel 1 of address 1, response +00.000.
Reference | $AA4N
Modules | I-87024


Baudrate Table
Configuration Code | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 0A
Baudrate(bps) | 1200 | 2400 | 4800 | 9600 | 19200 | 38400 | 57600 | 115200


Command/Response String and Checksum
Command/Response Format
Command Format | (Leading)(Address)(Command)[CHK](cr)
Response Format | (Leading)(Address)(Response)[CHK](cr)

(Leading) | Leading character, like ~, $, #, @, %, !, ?, >.
(Address) | Address of specificed module, from 00 to FF. For some command like #**, the address is ** for all modules.
(Command/Response) | Command with parameters or response with data.
[CHK] | 2-character checksum. If the CheckSum is disabled, no [CHK] here.
(cr) | end-of-command character, character return(0Dh)

Calculate Checksum
  1. Calculate ASCII sum of all characters of (Leading), (Address) and (Command)(or (Response)).
  2. Mask the sum of string with 0ffh, or said only take the last 2 digits of the hex value of the sum.
    For example, if the sum is 01BCh, take the "BC" as the [CHK].

Example
  • Command string : $012
    1. Sum of string = `$'+`0'+`1'+`2' = 24h+30h+31h+32h = B7h

    2. The checksum is B7h, and [CHK] = "B7"

    3. Command string with checksum : $012B7(cr)

  • Response string : !01070600
    1. Sum of string : `!'+`0'+`1'+`0'+`7'+`0'+`6'+`0'+`0' =
      21h + 30h + 31h + 30h + 37h + 30h + 36h + 30h + 30h = 1AFh

    2. The checksum is AFh, and [CHK] = "AF"

    3. Response string with checksum : !01070600AF
      4. (cr)


Format Selection
Analog Input Module | I-87013, I-87015, I-87015T, I-87017 , I-87018
Analog Output Module | I-87022, I-87026, I-87024
Digital Input/Output Module | I-870xx
Counter/Frequency Input Module | I-87082

Back to Previous Page

Format Table for Analog Input Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Filter Selection | CheckSum Selection | Not Used | Not Used | Not Used | Not Used | Data Format Selection

Filter Selection | 0 = 60Hz rejection
 | 1 = 50Hz rejection
 | This setting is reserved for the I-87015/I-87015T and should be zero.
CheckSum Selection | 0 = CheckSum disable
 | 1 = CheckSum enable
Data Format Selection | 00 = Engineer Unit Format
 | 01 = % of FSR Format
 | 10 = 2's Complement Hexdecimal Format
 | 11 = Ohms in Engineer Unit Format For I-87013 Only

Example
Format Code | Description
00 | 60Hz rejection, CheckSum disabled, engineer unit format
41 | 60Hz rejection, CheckSum enabled, % of FSR format
82 | 50Hz rejection, CheckSum disabled, 2's complement hexdecimal format

Back to Previous Page

Format Table for Analog Output Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Not Used | CheckSum Selection | Slew Rate Control |  |  |  | Data Format Selection

CheckSum Selection | 0 = CheckSum disable
 | 1 = CheckSum enable
Slew Rate Control ( For 87022/26 ) | Set to 0.
Slew Rate Control ( For 87024 ) | 0000 = Immediate output
 | 0001 = 0.0625V/Second or 0.125mA/Second
 | 0010 = 0.125V/Second or 0.25mA/Second
 | 0011 = 0.25V/Second or 0.5mA/Second
 | 0100 = 0.5V/Second or 1.0mA/Second
 | 0101 = 1.0V/Second or 2.0mA/Second
 | 0110 = 2.0V/Second or 4.0mA/Second
 | 0111 = 4.0V/Second or 8.0mA/Second
 | 1000 = 8.0V/Second or 16.0mA/Second
 | 1001 = 16.0V/Second or 32.0mA/Second
 | 1010 = 32.0V/Second or 64.0mA/Second
 | 1011 = 64.0V/Second or 128.0mA/Second
 | 1100 = 128.0V/Second or 256.0mA/Second
 | 1101 = 256.0V/Second or 512.0mA/Second
 | 1110 = 512.0V/Second or 1024.0mA/Second
 | 1111 = 1024.0V/Second or 2048.0mA/Second
Data Format Selection | 00 = Engineer Unit Format

Example
Format Code | Description
00 | CheckSum disabled, immediate output, engineer unit format
44 | CheckSum enabled, 0.0625V/Second or 0.125mA/Second output slew rate, engineer unit format
10 | CheckSum disabled, 0.5V/Second or 0.25mA/Second output slew rate, engineer unit format

Back to Previous Page

Format Table for Digital Input/Output Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Not Used | CheckSum Selection | Not Used | Not Used | Not Used | Not Used | Not Used | Not Used

CheckSum Selection 0 = CheckSum disable
1 = CheckSum enable

Format Table for Counter/Frequency Input Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Not Used | CheckSum Selection | Not Used | Not Used | Not Used | Frequency Gate Time | Not Used | Not Used

CheckSum Selection 0 = CheckSum disable
1 = CheckSum enable

Frequency Gate Time 0 = 0.1 Second
1 = 1.0 Second


Type Selection
Module | Available Type
I-87013 | RTD Input
I-87015 | RTD Input
I-87015_T | Thermister Input
I-87017 | mV, V or Current Input
I-87018 | mV, V or Current Input Thermocouple Input
I-87022 | Analog Output
I-87024 | Analog Output
I-87026 | Analog Output
I-870xx | Digital Input/Output
I-87082 | Counter/Frequency Measurement

Back to Previous Page

Type 00 to 06 Definition
Type Code | Input Range | Data Format | Full Scale | Zero | Negative Full Scale
00 | -15mV to +15mV | Engineer Unit | +15.000 | +00.000 | -15.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
01 | -50mV to +50mV | Engineer Unit | +50.000 | +00.000 | -50.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
02 | -100mV to +100mV | Engineer Unit | +100.00 | +000.00 | -100.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
03 | -500mV to +500mV | Engineer Unit | +500.00 | +000.00 | -500.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
04 | -1V to +1V | Engineer Unit | +1.0000 | +0.0000 | -1.0000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
05 | -2.5V to +2.5V | Engineer Unit | +2.5000 | +0.0000 | -2.5000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
06 | -20mA to +20mA with 125 ohms resistor | Engineer Unit | +20.000 | +00.0000 | -20.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000

Back to Previous Page

Type 08 to 0D Definition
Type Code | Input Range | Data Format | Full Scale | Zero | Negative Full Scale
08 | -10V to +10V | Engineer Unit | +10.000 | +00.000 | -10.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
09 | -5V to +5V | Engineer Unit | +5.0000 | +0.0000 | -5.0000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0A | -1V to +1V | Engineer Unit | +1.0000 | +0.0000 | -1.0000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0B | -500mV to +500mV | Engineer Unit | +500.00 | +000.00 | -500.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0C | -150mV to +150mV | Engineer Unit | +150.00 | +000.00 | -150.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0D | -20mA to +20mA with 125 ohms resistor | Engineer Unit | +20.000 | +00.0000 | -20.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000

Back to Previous Page

Thermocouple Type Definition
Type Code | Thermocouple Type | Data Format | Max Value | Min Value
0E | J Type | Engineer Unit | +760.00 | -210.00
 |  | % of FSR | +100.00 | -027.63
 |  | 2's Complement HEX | 7FFF | DCA2
0F | K Type | Engineer Unit | +1372.0 | -0270.0
 |  | % of FSR | +100.00 | -019.68
 |  | 2's Complement HEX | 7FFF | E6D0
10 | T Type | Engineer Unit | +400.00 | -270.00
 |  | % of FSR | +100.00 | -067.50
 |  | 2's Complement HEX | 7FFF | A99A
11 | E Type | Engineer Unit | +1000.0 | -0270.0
 |  | % of FSR | +100.00 | -027.00
 |  | 2's Complement HEX | 7FFF | DD71
12 | R Type | Engineer Unit | +1768.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
13 | S Type | Engineer Unit | +1768.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
14 | B Type | Engineer Unit | +1820.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
15 | N Type | Engineer Unit | +1300.0 | -0270.0
 |  | % of FSR | +100.00 | -020.77
 |  | 2's Complement HEX | 7FFF | E56B
16 | C Type | Engineer Unit | +2320.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
17 | L Type | Engineer Unit | +800.00 | -200.00
 |  | % of FSR | +100.00 | -025.00
 |  | 2's Complement HEX | 7FFF | E000
18 | M Type | Engineer Unit | +100.00 | -200.00
 |  | % of FSR | +050.00 | -100.00
 |  | 2's Complement HEX | 4000 | 8000
19 | L Type DIN43710 | Engineer Unit | +900.00 | -200.00
 |  | % of FSR | +100.00 | -022.22
 |  | 2's Complement HEX | 7FFF | E38F

Thermocouple Input Type Over/Under Range Response
Data Format | Over Range | Under Range
Engineer Unit | +9999 | -0000
% of FSR | +9999 | -0000
2's Complement HEX | 7FFF | 8000

Back to Previous Page

RTD Type Definition
Type Code | RTD Type | Data Format | Max Value | Min Value
20 | Platinum 100 a = 0.00385 -100 to 100 degree Celsius | Engineer Unit | +100.00 | -100.00
 |  | % of FSR | +100.00 | -100.00
 |  | 2's complement HEX | 7FFF | 8000
 |  | Ohm | +138.50 | +060.25
21 | Platinum 100 a = 0.00385 0 to 100 degree Celsius | Engineer Unit | +100.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +138.50 | +100.00
22 | Platinum 100 a = 0.00385 0 to 200 degree Celsius | Engineer Unit | +200.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +175.84 | +100.00
23 | Platinum 100 a = 0.00385 0 to 600 degree Celsius | Engineer Unit | +600.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +313.59 | +100.00
24 | Platinum 100 a = 0.003916 -100 to 100 degree Celsius | Engineer Unit | +100.00 | -100.00
 |  | % of FSR | +100.00 | -100.00
 |  | 2's complement HEX | 7FFF | 8000
 |  | Ohm | +139.16 | +059.58
25 | Platinum 100 a = 0.003916 0 to 100 degree Celsius | Engineer Unit | +100.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +139.16 | +100.00
26 | Platinum 100 a = 0.003916 0 to 200 degree Celsius | Engineer Unit | +200.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +177.13 | +100.00
27 | Platinum 100 a = 0.003916 0 to 600 degree Celsius | Engineer Unit | +600.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +317.28 | +100.00
28 | Nickel 120 -80 to 100 degree Celsius | Engineer Unit | +100.00 | -080.00
 |  | % of FSR | +100.00 | -080.00
 |  | 2's complement HEX | 7FFF | 999A
 |  | Ohm | +200.64 | +120.60
29 | Nickel 120 0 to 100 degree Celsius | Engineer Unit | +100.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +200.64 | +120.60
2A | Platinum 1000 a = 0.00385 -200 to 600 degree Celsius | Engineer Unit () | +600.00 | -200.00
 |  | % of FSR | +100.00 | -033.33
 |  | 2's complement HEX | 7FFF | D556
 |  | Ohm | +3137.1 | +0185.2
2B | Cu 100 a = 0.00421 -20 to 150 degree Celsius | Engineer Unit () | +150.00 | -020.00
 |  | % of FSR | +100.00 | -013.33
 |  | 2's complement HEX | 7FFF | EEEF
 |  | Ohm | +163.17 | +091.56
2C | Cu 100 a = 0.00421 0 to 200 degree Celsius | Engineer Unit () | +200.00 | -000.00
 |  | % of FSR | +100.00 | -000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +167.75 | +090.34
2D | Cu 1000 a = 0.00421 -20 to 150 degree Celsius | Engineer Unit () | +150.00 | -020.00
 |  | % of FSR | +100.00 | -013.33
 |  | 2's complement HEX | 7FFF | EEEF
 |  | Ohm | +1631.7 | +0915.6

Note :
1.Type 2B, 2C and 2D are only used in the I-87015

RTD Input Type Over/Under Range Response
For I-87013 |  |
Data Format | Over Range | Under Range
Engineer Unit | +9999 | -0000
% of FSR | +9999 | -0000
2's Complement HEX | 7FFF | 8000
For I-87015 |  |
Data Format | Over Range | Under Range
Engineer Unit | +999.99 | -999.99
% of FSR | +999.99 | -999.99
2's Complement HEX | 7FFF | 8000

Back to Previous Page

Thermistor Type Definition
60 | Precon -- ST-A3 -30 to 240 degree Fahrenheit | Engineer Unit | +240.00 | -030.00
 |  | % of FSR | +100.00 | -012.50
 |  | 2's complement HEX | 7FFF | F000
 |  | Ohm | +000539.4 | +173600.0
61 | Type u Fenwell -50 to 150 degree Celisus | Engineer Unit | +150.00 | -050.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | D556
 |  | Ohm | +000037.2 | +134020.0
62 | Type u Fenwell 0 to 150 degree Celisus | Engineer Unit | +150.00 | -000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +000037.2 | +006530.0

Thermistor Input Type Over/Under Range Response
For I-87015T |  |
Data Format | Over Range | Under Range
Engineer Unit | +999.99 | -999.99
% of FSR | +999.99 | -999.99
2's Complement HEX | 7FFF | 8000

Back to Previous Page

Analog Output Type Definition
Type Code | Output Range | Data Format | Max Value | Min Value
30 | 0 to 20mA | Engineer Unit | +20.000 | +00.000
31 | 4 to 20mA | Engineer Unit | +20.000 | +04.000
32 | 0 to 10V | Engineer Unit | +10.000 | +00.000
33 | -10 to 10V | Engineer Unit | +10.000 | -10.000
34 | 0 to 5V | Engineer Unit | +05.000 | +00.000
35 | -5 to 5V | Engineer Unit | +05.000 | -05.000

Back to Previous Page

I-87022 Analog Output Type Definition (T)
Type Code | Output Range | Data Format | Max Value | Min Value
0 | 0 to 20mA | Engineer Unit | 20.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFF | 000
1 | 4 to 20mA | Engineer Unit | 20.000 | 04.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFF | 000
2 | 0 to 10V | Engineer Unit | 10.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFF | 000

Back to Previous Page

I-87026 Analog Output Type Definition (T)
Type Code | Output Range | Data Format | Max Value | Min Value
0 | 0 to 20mA | Engineer Unit | 20.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFFF | 0000
1 | 4 to 20mA | Engineer Unit | 20.000 | 04.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFFF | 0000
2 | 0 to 10V | Engineer Unit | 10.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFFF | 0000

Back to Previous Page

I-87022 and I-87026 Slew Rate Control Definition (S)

Slew Rate Control Code
( For I-87022/26 ) 		0 = Immediate output
1 = 0.0625V/Second or 0.125mA/Second
2 = 0.125V/Second or 0.25mA/Second
3 = 0.25V/Second or 0.5mA/Second
4 = 0.5V/Second or 1.0mA/Second
5 = 1.0V/Second or 2.0mA/Second
6 = 2.0V/Second or 4.0mA/Second
7 = 4.0V/Second or 8.0mA/Second
8 = 8.0V/Second or 16.0mA/Second
9 = 16.0V/Second or 32.0mA/Second
A = 32.0V/Second or 64.0mA/Second
B = 64.0V/Second or 128.0mA/Second
C = 128.0V/Second or 256.0mA/Second
D = 256.0V/Second or 512.0mA/Second
E = 512.0V/Second or 1024.0mA/Second

Back to Previous Page

Digital Input/Output Type Definition
Type Code | Description
40 | Digital Input/Output

Counter/Frequency Type Definition
Type Code | Description
50 | Counter Mode
51 | Frequency Measurement