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Introduction

The following topics are covered in this chapter:

0 Overview
O System Requirements

0 Specifications
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Overview

Moxa has pioneered the concept of “active type” OPC software in the automation industry. The patented

MX-AOPC UA Server offers both polling (Modbus protocol) and non-polling (Moxa AOPC protocol) architectures
alongside the standard OPC UA protocol, giving users the alternative of pull or push-based communication from
Moxa’s devices. OPC UA (Unified Architecture), which features more secure and reliable data communication
between OPC servers and clients, is the next generation OPC standard (IEC 62541). By using Moxa’s MX-AOPC

UA Server, users can enjoy more secure and reliable data exchange and control.
The MX-AOPC UA Server includes:

e Server Runtime Service: Starts as a service by default after installation.

¢ Configuration Console: An offline configuration tool for configuring server settings.

e Viewer: An OPC client that allows developers, testers, and integrators to easily view tag values and test

MX-AOPC UA Server and connections.

System Requirements

Hardware Requirements

CPU: Intel Pentium 4 or above

RAM: 512 MB (1024 MB recommended)
Communication Interface: Ethernet or serial

Software Requirements

Operating System: Microsoft Windows XP/Vista/7/8, Microsoft Windows Server 2003/2008/2012

Editor (optional): Microsoft Office 2003 (Access or Excel) or later

Specifications

www.ipc2u.ru

OPC Server Specifications

OPC Unified Architecture: 1.01

OPC Data Access: 1.0a, 2.0, 2.053a, 3.0

Device Protocols: Moxa AOPC, Modbus/TCP Client, Modbus/RTU Client

Products that Support AOPC Protocol
ioLogik: ioLogik 2500 series

Note: Please check Moxa’s website for the most up-to-date list of supported products.

Fully Supported OPC UA Server Profiles
Standard UA Server Profile

Core Server Facet

e User Token - User Name Password Server Facet
e SecurityPolicy - None

Data Access Server Facet

UA-TCP UA-SC UA Binary

User Token - X509 Certificate Server Facet
SecurityPolicy - Basic128Rsal5

SecurityPolicy - None

www.moxa.pro
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Getting Started

www.ipc2u.ru

The following topics are covered in this chapter:

a

Qoaaoaa

aa

Installing MX-AOPC UA Server
Configuring Active Tags

Opening the Configuration Console
Configuring Server Settings
Configuring Devices and Tags

» Adding a Modbus Device

» Creating Modbus Tags

Updating Configurations to the Server
Using the Viewer to Check Tag Values
Configuring OPC UA Settings

www.moxa.pro



Installing MX-AOPC UA Server

MX-AOPC UA Server can be downloaded from the Moxa website at www.moxa.com.

After downloading the file, unzip it and run setup.exe. The installation program will guide you through the

MX-AOPC UA Server installation process.

Configuring Active Tags

MX-AOPC UA Server will automatically receive active tags from Moxa’s remote devices once the tags are
created. Refer to the device’s user’s manual to learn how to use the device’s configuration utility to create

Opening the Configuration Console

www.ipc2u.ru

active tags.

Open MX-AOPC UA Server’s configuration console from the Windows Start menu: Start > All Programs >
MOXA - I0 Server > MX-AOPC UA Suite > MX-AOPC UA Server.

The configuration console is an offline configuration tool for configuring Server Runtime settings. When the
configuration console is launched, it will automatically get the latest configurations from the Server Runtime.
If any active tag is received, the device will be listed in the Active Device List. To manually get the latest
configurations from the Server Runtime, click the Get Configuration from Server icon on the MX-AOPC UA
Server menu bar. To manually update the settings to the Server Runtime, click the Update Configuration to

Server icon on the menu bar.

Eile Edit View Tools Runtime Help

FEENIASDR A

B

R@

9 3

L

B % Active Device List Tag Name

e E2242-01 (00:90:e8: 16:e7: 1. "
) ! 2 % E2242-01.DI-00

% Modbus Device Group List _
% E2242-01.01-01

¥ E2242-01.D1-02
W £2242-01.01-03
W E2242-01.01-04
W £2242-01.01-05
W £2242-01.01-06
W £2242-01.01-07
W £2242-01.01-08
W E2242-01.01-09
W £2242-01.01-10
W £2242-01.01-11

Data Type
Boolean
Boolean
Boolean
Boolean
Boolean
Boolean
Boolean
Boolean
Boolean
Boolean
Boolean
Boolean

Wy E2242-0 1.5ysConnect-00 Boolean

Access Rights

Read-only
Read-only
Read-only
Read-only
Read-only
Read-only
Read-only
Read-only
Read-only
Read-only
Read-only
Read-only
Read-only

Description
DI

DI

CI

DI

DI

Door Status
DI

DI

DI

DI

DI

DI

System Connection

Date Time Event

2014/12f29 11:56:04 Successfully got configuration from server,

4 | 1

L3

Service Status: Running Time: 11:57:01

Device Count: 1

OPC Client Count: 0 l

www.moxa.pro
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NOTE

The first time you use MX-AOPC UA Server, we recommend turning off the Windows Firewall and then checking
to see if MX-AOPC UA Server is able to receive active tags. If it can, turn the Windows Firewall back on and

check it again. If MX-AOPC UA Server does not receive any active tags after you turn on the Windows Firewall,
add aopcservice.exe in the Firewall Inbound Rules, and set it to Allow for Private, Public, and Domain network

profiles.

NOTE

Be sure to update the settings to the Server Runtime after changing the configuration. Otherwise, the Server
Runtime will not reflect the configuration changes made using the configuration console.

Configuring Server Settings

Before configuring devices and tags, configure the server settings described below under the Tools menu.

File Edit \iew |Tools| Runtime Help

S | Serial Port Settings

! | g BF
. AQPC Settings
B Active Device
- L ) E2242-01 DCOM Configuration
= Yodbus Devil OPC UA Settings
Viewer
System Log

Change Password

Options

: _
v v sorcuasns TR

x}{l,l
an

—

¢ Change Password

We strongly recommend changing the password the first time you use the Configuration Console. The
default password is *moxa”, which is needed for verification when updating configurations to the Server

Runtime or exporting the system log to a text file.

NOTE

When connecting an OPC UA client to MX-AOPC UA Server, use account name “admin” (the account name
cannot be changed) and whatever the password is. The password is the same as the system password, which
can be updated using Tools > Change Password.

www.ipc2u.ru
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e Serial Port Settings

Configure the PC’s Serial Port Settings if a serial device is connected to MX-AOPC UA Server.

Port Baudrate Parity Data Bits Stop Bits Flow Contral A
COM1 115200 MNone g 1 MNone D
comz 115200 MNaone 8 1 MNone
COoM3 115200 MNaone 8 1 None
COM4 115200 MNone d 1 Mone
COMS5 115200 MNaone 8 1 MNone
COMa 115200 MNone 8 i MNone
COM7 115200 MNone d 1 MNone
COoma 115200 MNone 8 1 None
COomM3a 115200 MNone 8 1 MNone i
Baud Rate: 115200 - Flow Control:

o |

e AOPC Settings
Configure AOPC Settings if a Moxa device updates Active Tags to MX-AOPC UA Server.

AQPC Settings

Default Network Interface: [I.ntal(Rj 82577LM Gigabit Network Connection - ]

Active Tag Listen Port: 9500 Enabled

Command Timeout: 30 sec(s)

Heartbeat Tolerance: 30 sec(s)

OK

| [ cancel

Configuring Devices and Tags

Adding a Modbus Device

1. Click the Modbus Device Group List to select it and then click the New Device Group icon and type in
the name of the device group.

w oo T

File Edit View Tools Runtime Help

www.ipc2u.ru

{4 Modbus Device Group List

Group Mo

"

p
Device Group Property . ‘

Device Group Mame:

Ok

|| cancel

www.moxa.pro



2. Click the New Device icon and then configure the device properties.

U U T R —

__Eile Edit  View _Ipols Runtime __Help -

e > - . = @ %u

rEEalllsEaKiAeH eI L
Enabled Communication Part

-8 Active Device List Device Name

[ [T

i DeviceGroupl

Device Name: Enable Data Collection

Communication Port: | Intel(R) 82577LM Gigabit Netwe ~ |

Protocol: Modbus/TCP protocol
Device Settings Timeout Settings

Unit ID: [1 Reconnect Delay: 3000

IP Address: [ B : . Reconnect Cycles: 3

Port: 502 Cyde Delay: 3
Polling Timeout: 3000

Poling Retries: 3

[ Ble Edit View Tools Runtime Help

TE R 10 @ 98
TEEOdsSK i858 .‘ |
‘ & "‘ Active Device List Device Name Enabled Communication Port Protocol un||/
i g E2242-01 (00:90:e8:16:e7: 1! 1
J ( - e7:13) Devicel Yes Intel(R) 82577LM Gigabit ...  Modbus/TCP protocal 1 (|

lodbus Device Group List

28 Jo=c<Grovp

- ) Devicel

Creating Modbus Tags

1. Click the device name to select it and then click the New Tag Group icon and type in the name of the tag
group.

(& oreunsee T

File Edit Wiew Tools Runtime Help
W mm adaE @

E‘I Active Device List Tag Group

www.ipc2u.ru WWW.Mmoxa.pro



2. Click the New Tag icon and then configure the tag properties.

Bl MX-AOPCUA sm&“

Eile Edit View Tools Runtime Help

!J“'I

rl@-

AR R

= JI Active Device List
. ) E2242:01(00:90:¢8: 16:7: 150
=2 ‘ll Modbus Device Group List ‘

=& DeviceGroupl !

Tag Tyy

Tag Mame:

Description:

Start Address; 0

Function Code: [R.ead,-'WritE Coils (Moo

Data Type: |Boolean

Access Right: Read/Write

3. The tag will be listed in the tag group.

Ele Edit View Tools Runtime Help

oy gl

AsSH & AR

IR

=8 Ii Active Device List
H - [} E2242-01 (00:90:e8: 16:e7:15)
'li Modbus Device Group List
(=)-E) DeviceGroupl
=] B Devicer

Tag Name
L Tagl

Tag Type
Polling

Functin Code Start Address Da
1] Qooo Bo

Updating Configurations to the Server

When you finish updating the configuration, click the Update Configuration to Server icon to update the
configuration to the Server Runtime. When the Verify Password window pops up, enter the correct password

and then click OK to activate the changes.

Eile Edit View Tools Runtime Help

© e ke T T —

NAsS& 42 g @]

=i Active Device List

L ) E2242-01 (00:90:e8: 16:27:15)
-3 Modbus Device Group List

II Ei] DeviceGroupl

Group No
1

£ B Devicel
i TagGroupl

www.ipc2u.ru

Group Mame

DeviceGroupl

Werify Password

Please enter password:

[ cancel

| ok

www.moxa.pro



Using the Viewer to Check Tag Values
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After completely updating the Server Runtime settings, click the Viewer icon to open the viewer to check that

the tag value is correct.

i MX-AOPC UA Se

Eile Edit View Tools Runtime Help

.y B

NAsSR X 2edsaE]

S8 Active Device List
B E2242-01(00:90:28: 16:27:15)

[E8F "} Modbus Device Group List

EJ) DeviceGroupl

Group No Group Name

1 DeviceGroupl

The device tree in the left panel should be the same as the tree displayed by the configuration console. Click a

tag group name to display the group’s tag values in the right panel.

&4 MX-AOPC UA View =

File Tools Help

-1 Active Device List
B E2242-01 (00:90:e8:16:7:15)
=11 Modbus Device Group List
(-7 DeviceGroup1
= [ Devicel

= R

i Tagl Boolean

Tag Mame Data Type

Timestamp Q
21:20:08 2014/12/29 G

Date Event

2014/12(29 The tag E2242-01.DI-00 changes the value from 1to 0
2014/12(25 The tag DeviceGroup1.Device 1. TagGroup1.Tagl changes the value from 1to 0
2014{12(29 The tag E2242-01.DI-00 changes the value from 0 to 1

2014/12(25 The tag DeviceGroup1.Device 1. TagGroup 1. Tagl changes the value from 0 to 1

L8

Time: 13:22:11

www.moxa.pro



Configuring OPC UA Settings

You should configure OPC UA settings before connectin

g an OPC UA client to MX-AOPC UA Server. To access

OPC UA Settings options, click Tools > OPC UA Settings. Instructions for each option are given below.

ARRG NI N

Group Mame

File Edit View [Tools| Runtime Help
| g Serial Port Settings
LES B .
AOPC Settings
= Active Device
P e E2242-01 DCOM Configuration
=R OPC UA Settings v
=~ DeviceGr
= 1 Devic Viewer
- System Log 3

Server Endpoints Settings
Security Policy

Certificates Management

Change Password

Options

e Server Endpoints Settings

“Server Endpoints Settings” are a list of interfaces that UA clients can use to communicate with MX-AOPC

UA Server. MX-AOPC UA Server supports Universal

To add a new interface to the list, select the approp

Resource Locator (URL) binary type protocols.

riate network interface in the Network Interface

drop-down box and type the port number for the URL in the Port Number input box. Click Add to add this

new server endpoint to the list.

s ecpantssetings S

URL
opc. tep: /192, 168, 12, 112: 53192 /MXAOPC [UAServer

Status
Valid

Metwork Interface: [InteI{R_} 82577LM Gigabit Network Connection A

| Port Mumber: 53132

opc. bop:/f192, 168, 12, 112: 53192 /MK AOPC UAServer

add || Deete ||

Help

P |

e Security Policy

The security policy is applied to connections between OPC UA clients and MX-AOPC UA Server. Security
options that can be selected are None, Basic128Rsal5: Sign, or Basic128Rsal5: Sign and Encrypt.
If Basic128Rsal5: Sign, Basic128Rsal5: Sign and Encrypt, or both of these options are selected, you will
need to configure Certificates Management settings (see below).

Security Policy SettingA e
Mone
[ Basic128Rsa15 - Sign
[~ Basic128Rsa15 - Sign and Encrypt
[ oK J [ Cancel ] |

www.ipc2u.ru WWW.moxa.pro



NOTE The default Account and Password for connecting an OPC UA client to the server are:
Account: admin
Password: moxa
The account name cannot be changed. To change the password, click Tools > Change Password.

¢ Certificates Management

If the security policy is set to Basic128Rsal5: Sign, Basic128Rsal5: Sign and Encrypt, or both,
importing an OPC UA client’s CA (Certificate Authority) file into MX-AOPC UA Server, and exporting the
MX-AOPC UA Server’s CA file to OPC UA Clients are both required.

Click the Trust Clients tab, click Import, and select the client’s CA file to import it into MX-AOPC UA
Server.

Certificates Management |

Trust Clients | Instance Certificates

Client Name TERI
v A Locel Discovery Server vrncharleszk-chen moxe. com T A LocalDiscovers

Impodt... Export... Eemove Reject View Certificate...

I Close I [ Help J

Click the Instance Certificates tab and click Export Server Certificate to export MX-AOPC UA Server's
CA file to OPC UA Clients.

Certificates Management X ]
Instamce Certificates
( Tigw Server Certificate... Certificate MX-AOPC UA Server
is from 2014/10/28 09:42:23 AM to
l Export Server Certificate... I 201971042 09:42:23 AM
( Reissue Certificate |
I Close I l Help I

Click the Update Configuration to Server icon to enable any changes that have been made to the OPC UA
configuration.

NOTE After reissuing certificates or re-installing MX-AOPC UA Server, you will need to once again export the Server
Certificate to OPC UA clients.

www.ipc2u.ru WWW.moxa.pro



3

Configuration Console

The following topics are covered in this chapter:

O Main Screen Overview
O Menu Items
» File
Edit
View
Tools

Runtime

YV V VYV VY V

Help

www.ipc2u.ru WWW.moxa.pro



Main Screen Overview

www.ipc2u.ru

MX-AOPC UA Server’s configuration console displays the mapped I/O device with the settings of every I/0 tag.
It also shows the Server Runtime status and number of OPC clients.

File Edit View Tools Runtime Help 2

EERNISDRKALEG IS N
-4 Active Device List Tag Name Data Type Access Rights Description
B BE2242-01 (00:90:e8: 16:27:15) -
-1 Modbus Device Group List :Q' E2242-01.DI-00 Boolean Read-only DI
& £ DeviceGroup1 “S‘u‘ E2242-01.0I-01 Boolean Read-only DI
& ) Devicel Q‘ E2242-01.DI-02 Boolean Read-only DI
. J® TagGroupl "S‘u‘ E2242-01.D1-03 Boolean Read-only DI
5 E2242-01.01-04 Boolean Read-only oI
¥ E2242-01.D1-05 Boolean Read-only Door Status
W E2242-01.D1-06 Boolean Read-only DI
W E2242-01.01-07 Boolean Read-only Dol
4 W E2242-01.01-08 Boolean 5 Read-only ol
¥ E2242-01.01-09 Boolean Read-only DI
¥ E2242-01.01-10 Boolean Read-only DI
W E2242-01.D1-11 Boolean Read-only DI
& E2242-01.5ysConnect-00  Boolean Read-only System Connection
Date Time Event A
2014/12/29 13:22:01 The value of the tag 'E2242-01.DI-11'is changed to 0 =
2014{12/29 13:22:01 The value of the tag 'E2242-01.DI-10' is changed to 0
20141229 13:22:01 The value of the tag 'E2242-01.DI-09' is changed to 0
2014/12/29 13:22:01 The value of the tag 'E2242-01.DI-08' is changed to 0
2014/12/29 13:22:01 The value of the tag 'E2242-01.DI-07 is changed to 0
2014/12/29 13:22:01 The value of the tag 'E2242-01.DI-06' is changed to 0 6
2014{12/29 13:22:01 The value of the tag 'E2242-01.DI-05'is changed to 0
20141229 13:22:01 The value of the tag 'E2242-01.DI-04 is changed to 0
20141229 13:22:01 The value of the tag 'E2242-01.DI-03 is changed to 0
2014/12/29 13:22:01 The value of the tag 'E2242-01.DI-02' is changed to 0 I
2014/12/29 13:22:01 The value of the tag 'E2242-01.DI-01'is changed to 0
2014/12/29 13:22:01 The value of the tag 'E2242-01.DI-00' is changed to 0
20141229 13:22:01 The value of the tag 'DeviceGroup1.Device 1. TagGroup1.Tagl' is changed to 0
20141229 13:21:57 The value of the tag 'E2242-01.5ysConnect-00' is changed to 1
Jn|14.’13‘|f7q 13:21:57 The value of the tan 'F2242-01.01-11' is rhanned tn 01 X4
1] m

| 3
OPC Client Count: 1 10

Service Status: Running 7 Time: 13:26:58 & Device Count: 2 &

No. |Zone Description

1 Software Title Displays the name of the software: MX-AOPC UA Server

2 Menu All configuration functions

3 Quick Launch Bar Frequently used icons

4 Device View All devices and tags

5 Detailed View Detailed settings of the devices and tags

6 Log View Server Runtime logs

7 Server Runtime Status Shows if the Server Runtime Service is Running or Stopped
8 Server Time Displays the server time (same as the PC’s time)

9 Numbers of Device Displays the number of devices listed in Device View

10 Numbers of OPC Client Displays the number of OPC clients connected to MX-AOPC UA Server

www.moxa.pro



Menu Items
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All operations can be accessed from the following Menu items.

Use the File menu to manage project files, device tags, and server configuration.

& vorc Ao

Edit View Tools Runtime Help

Mew Ctrl+MN p
Open... Corl+O
Save Ctrl+5

Save As...

Import Device Tags (.csv)

Export Device Tags (.csv)

Get Configuration from Server

Update Configuration to Server

1 Test-D.acp
2 Test-C.aop
3 Test-B.aop
4 Test-Aaop

Exit

e New: Create a new project file.
e Open: Open an existing project file.

e Save: Save the current project.

e Save As: Save the current project file as another project with a different filename.

e Import Device Tags (.csv): Import device tags into a Modbus device from a csv file.

Item Format Length Note
GroupName 0to9, Ato Z, ato z, Symbols 30 ".” is not allowed.
TagName 0to9, Ato Z, Symbols 30 ".” is not allowed.
FunctionCode 1to4 1 1: Read/Write Coils
2: Read Discrete Inputs
3: Read Input Registers
4: Read/Write Holding Registers
StartAddress 0 to 65535 5
DataType Boolean - e Use Boolean with
Unsigned short integer FunctionCode 1 or 2.
Unsigned integer e Use other DataTypes with
Float FunctionCode 3 or 4.
Description 0to9, Ato Z, ato z, Symbols 25

o Export Device Tags (.csv): Export device tags from a Modbus device to a csv file.

e Get Configuration from Server: Get the latest configuration from the Server Runtime.

« Update Configuration to Server: Update the configuration to the Server Runtime from the Configuration

Console.

* Previous saved files: Quickly open previously saved project files.

e Exit: Close the Configuration Console.
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NOTE Active Tags cannot be imported into an Active Device folder in the Configuration Console from a csv file, or vice
versa. Active Tags are automatically created by a Moxa active tag device. Refer to the Specifications section
for the Products that Support AOPC Protocol, and refer to the device’s user’s manual to see how to create
active tags using the device’s configuration utility.

NOTE To get a csv template, create a Modbus device and execute the Export Device Tags (.csv) function from the
Modbus Device.

Edit

Use the Edit menu to edit settings of devices and tags.

r S

Eile [Edit| VWiew Tools Runtime Help

Cut Ctrl+x 9 &y
| Copy Ctrl+C

- Paste Cirl+V  [Tag Mame
! Delete Del [ Tagi
Select All Ctrl+A

Mew Device Group

T e oyt
Mew Lievice

Mew Tag Group

Mew Tag

Properties...

e Cut: Cut a tag group or selected tags.

e Copy: Copy a tag group or selected tags.

e Paste: Paste a cut or copied tag group into a device, or paste cut or copied tags into a tag group.
o Delete: Delete the selected device, a selected tag group, or selected tags.

e Select All: Select all tags in a tag group.

e New Device Group: Create a new device group.

¢ New Device: Create a new Modbus device.

e New Tag Group: Create a new tag group.

e New Tag: Create a new tag.

* Properties: Modify the settings of an existing device group, device, tag group, or tag.

NOTE The properties of an active device or active tag cannot be modified from the configuration console. Refer to the
device’s user’s manual to see how to use the device’s configuration utility to change active device or active tag
settings.
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View

Use the View menu to change the display settings of the Device View panel.

Voo R

File Edit [View| Tools Runtime Help
= Expand All Devices Ctrl+H ‘
i Collapse All Devices Ctrl+H

-l Active DEVIEE IS | T

e Expand All Devices: Expand all devices in the Device View panel.

e Collapse All Devices: Collapse all devices in the Device View panel.

Tools

Use the Tools menu to configure serial ports, OPC settings, system log, password, console environment

settings, or to launch Viewer.

- =

File Edit View IIo-cl-s| Runtime Help

s = Serial Port Settings }Q
g B

AQPC Settings —
= Active Device
L L ) E2242-01 DCOM Configuration
------ it Y Modbus Devid OPC UA Settings >

Viewer

System Log L

Change Password

Cptions

e Serial Port Settings

Port Baudrate Parity Data Bits Stop Bits Flow Control =
COM1 115200 Naone 8 1 Nane D
ComM2 115200 Naone 3 i Naone
COM3 115200 None 3 1 Nane
COM4 115200 Naone 3 1 MNaone
COMS 115200 Nane 3 1 MNone
COM& 115200 Naone 3 1 Naone
COM7 115200 Naone 3 1 Naone
COM3 115200 None 8 1 None
COMS 115200 None 8 1 None =
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Baud Rate: 300 to 921600 bps; default: 115200 bps

Flow Control: None, RTS/CTS, or XON/XOFF; default: None
Data Bits: 5, 6, 7, or 8; default: 8

Stop Bits: 1 or 2; default: 1

YV V V V V¥V

Parity: Even, Odd, or None; default: None
AOPC Settings

Default Network Interface: lInheI{Rj 82577LM Gigabit Network Connection -
Active Tag Listen Port: 9900 Enabled
Command Timeout: 30 sec(s)
Heartbeat Tolerance: 30 sec(s)
[ OK ] l Cancel

> Default Network Interface: Select a network interface that remote devices can use to connect to
MX-AOPC UA Server.

> Active Tag Listen Port: The preferred TCP socket port for receiving active tags from remote devices
(default: 9900).

» Command Timeout: The socket timeout interval (Port: 9500 and 9900) for controlling output
channels on remote devices: 0 to 60; default: 30 sec.

> Heartbeat Tolerance: An additional timeout interval to wait for a heartbeat signal from remote
devices: 0 to 60; default: 30 sec.

DCOM Configuration: Configure DCOM settings for your security policy. Refer to Appendix A for details.
OPC UA Settings

Ele Edit View EIoos Runtime Help
R Serial Port Settings % i~ - ﬁ
iaf ¥ PS-E-N: R K
AQPC Settings
-8 Active Device Group Name
-l DCOM Configuration
I G- ) DeviceGr OPC UA Settings ] Server Endpoints Settings
s Security Policy
& tem Log . Certificates Management

Change Password

Options

» Server Endpoints Settings:

“Server Endpoints Settings” are a list of interfaces that UA clients can use to communicate with
MX-AOPC UA Server. MX-AOPC UA Server supports Universal Resource Locator (URL) binary type
protocols.

To add a new interface to the list, select the appropriate network interface in the Network Interface
drop-down box and type the port number for the URL in the Port Number (default: 53192) input box.
Click Add to add this new server endpoint to the list.
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Server Endpoints Settings X

URL Status
opc. top: {192, 168, 12, 112: 53192 MXAOPC UAServer Valid

Metwork Interface: IInteI{R) 82577LM Gigabit Network Connection hd

Port Number: 53192

opc. bep: 192, 168, 12, 112:53192/MXAQPC flUAServer

I Add I I Delete I [ Apply I [ Close H Help

>» Security Policy
The security policy is applied to connections between OPC UA clients and MX-AOPC UA Server. Security
options that can be selected are None, Basic128Rsal5: Sign, or Basic128Rsal5: Sign and
Encrypt. If Basic128Rsal5: Sign, Basic128Rsal5: Sign and Encrypt, or both of these options are
selected, you will need to configure Certificates Management settings (see below).

Security Policy Setting |t S

Mone
[ Basic128Rsa15 - Sign

|:| Basic128Rsal5 - Sign and Encrypt

0K l I Cancel

NOTE The default Account and Password for connecting an OPC UA client to the server are:
Account: admin
Password: moxa
The account name cannot be changed. To change the password, click Tools > Change Password.

» Certificates Management

If the security policy is set to Basic128Rsal5: Sign, Basic128Rsal5: Sign and Encrypt, or both,
importing an OPC UA client’s CA (Certificate Authority) file into MX-AOPC UA Server, and exporting the
MX-AOPC UA Server’s CA file to OPC UA Clients are both required.

Click the Trust Clients tab, click Import, and select the client’s CA file to import it into MX-AOPC UA
Server.
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Certificates Management lﬁ

Trust Clients | Instance Certificates
Client Name URI
+f UA Local Discovery Server um:charlessk-chen moxa.com: U ALocalDiscover,
] 1 b
Export... Eemove Eeject iew Certificate. .
[ Close ] [ Help ]

Click the Instance Certificates tab and click Export Server Certificate to export MX-AOPC UA
Server’s CA file to OPC UA Clients.

Certificates Management |
Instance Certificates
[ Fiew Server Cerfificate. ] Certificate M- ACOPC UA Server
is from 2014/10/28 09:42:23 AN to
[ Hxport Server Certificats_. | 0191102094323 AM
[ Reissue Certfivate ]
[ Close ] [ Help ]

Click the Update Configuration to Server icon to enable any changes that have been made to the
OPC UA configuration.

NOTE After reissuing certificates or re-installing MX-AOPC UA Server, you will need to once again export the Server
Certificate to OPC UA clients.
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e Viewer: Open the viewer to check that the tag value is correct.

e System Log

F=
e .

File Edit View IIo-c.'-s Runtime Help

g R

A

- Active Device
=B Y Modbus Devit
- DeviceGr

Serial Port Settings

AQPC Settings
DCOM Configuration
OPC UA Settings

Wiewer

System Log
Change Password

Options

PES-N-N: 1

Group Mame
; DeviceGroup 1l
r Sawve to Text File
Reset System Log
System Log Settings
|

> Save to Text File: Save MX-AOPC UA Server’s system log to a text file. You will be required to enter
a password (default password: moxa).

Verify Password e
il
Please enter password:
(111
o Jew ] |

> Reset System Log: Reset MX-AOPC UA Server’s system log. You will be required to enter a password
(default password: moxa).

T

ActiveQPC

@ Do you want to reset system log?

J[owe ]

Werify Password (S|
.
Please enter password:
sens
o [ conm

» System Log Settings: Defines the maximum number of records that can be saved in the MX-AOPC UA
Server’s system log: 1 to 30000; default: 30000.

Ewent Records:

30000

(1~30000)

o ][ conce

)
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¢ Change Password: Change the MX-AOPC UA Server’s system password. The password is required when
updating configurations to System Runtime, saving system logs to a text file, or resetting system log.
Length: 4 to 128; acceptable characters: Ato Z, ato z, 0 to 9, Symbols; default: moxa.

Change Password A [t S|

Old Passwaord:

Mew Password:

Confirm Password:

[ OK ” Cancel ]‘

e Options: Configure environment settings for the server’s configuration console.

Startup

(@) Get configuration from Server

() Open previous configuration file

Configuration File
[¥] Automatically save configuration every 10 min{s)
Automatically save configuration before updating to server

Automatically save configuration before exiting this console

[ Ok ] [ Cancel

NOTE If Automatically save configuration every xx min(s) is enabled, the configuration file will be automatically
saved only when a file name is defined. Be sure to save your configuration file after creating a new project file.

Runtime

Use the Runtime menu to Start, Stop, or Reinitialize Server Runtime Service.

Eile Edit View Tools [Euntime Help

= Ei Start Server Runtime Service

= il s
e “I‘ M Stop Server Runtime Service

& Active Device List Reinitialize Server Runtime Service pl
II =8} Modbus Device Group (S .

- DeviceGroup1 | I s
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Help
Use the Help menu to launch the server’s help documentation, to check the server’s license status, to add a

license file, or check server version.

w cacec ua sener

| File Edit View Tools Runtme [Help]
—_— o ﬁ I"] { Server Help E%

e ! M @ ) Licensing 4

-8 Active Device List Abcaits

=) . WModbus Device Group List | I T

[-E DeviceGroupl

Server Help: Launch MX-AOPC UA Server’s help documentation.

e Licensing

File Edit View Tools Runtime |Help

- s Ei %r. { Server Help ' "= e AN ,
A Q - z Licensing » License Info

: Active Denice List About... Add License File

=8 Y Modbus Device Group List " it
[-E ) DeviceGroupl ‘ I eviceGroup

License Info: Displays the server’s User Code, License Status, and the Time Remaining on the license.
Refer to Chapter 6: License Registration and Activation to learn how to activate the license.

vrcote

User Code: 161368128766

>

License Status: Trial Version

Time Remaining: 11 days

o ]

» Add License File: Import a license file after completing the license registration process. Refer to
Chapter 6: License Registration and Activation to learn how to activate the license.

About: Displays MX-AOPC UA Server’s version number and build number.

o
Moxa MYX-AQPC UA Server 1.0 build 14122910 E

ﬁ Copyright {C) 2014 Maoxa Inc.
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4

Management
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The following topics are covered in this chapter:

O Device Group

» Adding a Device Group

» Editing a Device Group

» Deleting a Device Group
O Active Devices

» Deleting an Active Device from the Active Device Group List
O Modbus Devices

» Adding a Modbus Device to a Device Group

» Editing a Modbus Device
» Deleting a Modbus Device
>

Moving a Modbus Device to a Different Device Group
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Device Group

In this section we explain how to use the configuration console to add, edit, and delete device groups.

MX-AOPC UA Server’s design logic is user-application oriented. As seen below, device groups can be created
based on application, such as SiteA or SiteB.

File Edit View

Bl MX-AOPC UA Server

Tools Runtime Help

oy 5

NASYK AR

SIE K I .

-0 SiteA

SiteB

ioLogik E2242
& Pump

ioLogik E2242
& Pump

=+ Active Device List Group No Group Name
W E2242-01(00:90:e8:16:27:15)

=Rt ¥ Modbus Device Group List

. ! SiteA
2 SiteB

Date

2014/12/29
2014/12/29
2014/12/29
2014/12/29
2014/12/29
2014/12/29
2014/12/29
2014/12/29
2014/12/29
2014/12/29
2014/12/29
2014/12/29
2014/12/29

Time Event

13:22:01 The value of the tag 'E2242-01.DI-11' is changed to 0
13%22:01 The value of the tag 'E2242-01.DI-10' is changed to 0
1%22:01 The value of the tag 'E2242-01.DI-09' is changed to 0
1322:01 The value of the tag 'E2242-01.DI-08' is changed to 0
13:22:01 The value of the tag 'E2242-01.DI-07 is changed to 0
1%22:01 The value of the tag 'E2242-01.DI-06" is changed to 0
1%22:01 The value of the tag 'E2242-01.DI-05' is changed to 0
1%22:01 The value of the tag 'E2242-01.DI-04 is changed to 0
13%22:01 The value of the tag 'E2242-01.DI-03' is changed to 0
13%22:01 The value of the tag 'E2242-01.DI-02' is changed to 0
1%22:01 The value of the tag 'E2242-01.DI-01' is changed to 0
13%22:01 The value of the tag 'E2242-01.DI-00' is changed to 0
13%22:01 The value of the tag 'DeviceGroup1.Device 1. TagGroup1.Tagl' is changed to 0

20|141’ 12/29
El

13:21:57 The value of the taa 'E2242-01.5vsConnect-00' is chanaed to 1
T

Service Status: Running Time: 13:55:46 Device Count: 3 OPC Client Count: 1

Adding a Device Group

www.ipc2u.ru

1. Right click Modbus Device Group List and then click New Device Group in the popup menu, or click
Modbus Device Group List to select it, and then click the New Device Group icon on the Quick Launch

toolbar.

File Edit View Tools Runtime Help

2. Type in the name of the device group (max. length = 30 characters;

!i Modbus Device Group Li

T — [ . —— “s'
EI!i Active Device List Group No

B E2242-01 (00:90:e8: 16:e7: 15)
st

Mew Device Group

Device Group Property ‘

Device Group Mame:

[ ok || concel

w o

." is not allowed), and then click OK.
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3. The new device group will be added to the Modbus Device Group List.

File Edit View Tools Runtime Help

CHE Bl
= JIi Active Device List Devi
P E J E2242-01 (00:90:8: 16:27:15)

E| ‘I Modbus Device Group List
------ £ DeviceGroup1

Editing a Device Group

Right click the device group you would like to edit and then click Properties in the popup menu, or click the
device group to select it and then click the Properties icon on the Quick Launch toolbar to open the properties
window.

(Fle Edit View JTools Runtme Help
—_— e

DEH .4

= JI Active Device List P —

I ) E2242-01 (00:90:8: 16:27: 15)
=B ‘li Modbus Device Group List

Mew Device

Delete Ctrl+D

Properties...

Deleting a Device Group

Right click the device group you would like to delete and then click Delete in the popup menu, or click the
device group to select it and then click the Delete icon from the Quick Launch toolbar.

- - :
i MH-ADPC UA Server

File Edit View Tools Runtime Help

DEHEONS

- ‘l Active Device List Device Mame Enabled
P B E2242-01(00:90:e8: 16:e7:15)
El ‘Ii Modbus Device Group List
...... i‘.
Mew Device
Delete Ctrl+D
Properties...

www.ipc2u.ru WWW.Mmoxa.pro



Active Devices

In this section we explain how to use the configuration console to delete active devices.

MX-AOPC UA Server will automatically receive the registration from a Moxa active device located at a remote
site. Refer to the Moxa I/O device’s user’s manual to learn how to use the device’s configuration utility to create

active tags.

Deleting an Active Device from the Active Device Group List

Right click the active device you would like to delete and then click Delete in the popup menu, or click the
active device to select it and then click the Delete icon from the Quick Launch toolbar.

File Edit View Tools Runtime Help

S EGY EEY Y Y6

EI B Active Device List Tag Name Data Type
| §E2242-01 (00:90:e8: 16:e7: 15
I : : 3 242-01.DI1-00 Boolean
=% Modbus Device Group Lis Delete
: 242-01.01-01 Boolean
------ il DeviceGroup1
"% E2242-01.01-02 Boolean
BEn £774711 M2 Brnlazn

Modbus Devices

In this section we explain how to use the configuration console to add, edit, delete, and move Modbus devices.

Adding a Modbus Device to a Device Group

Right click the device group you would like to add a new Modbus device to and then click New Device in the
popup menu. You may instead click the device group to select it and then click the New Device icon on the

Quick Launch toolbar.

File Edit View Tools Runtime Help

D= wallls &)

=R ]: Active Device List —
P B E2242-01 (D0:50:e8: 16:27: 15)
=% Modbus Device Group List

Mew Device

Delete Ctrl+D

Properties...
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Ethernet Communication Port
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If an Ethernet communication port is selected, the Device Property configuration window will appear as
shown below:

Device Property
Device Name: | EE0==8] [¥] Enable Data Collection
Communication Port: lInheI(R) 82577LM Gigabit Netwe -
Protocol: Modbus/TCP protocol
Device Settings Timeout Settings
Unit ID: |1 vJ Reconnect Delay: 3000 ms
IP Address: [+ TR AP | P Reconnect Cycles: 3
Port: 502 Cyde Delay: 3 sec(s)
|
Polling Timeout: 3000 ms
Poling Retries; 3
[ 0K l | Cancel |
Device Name: Name of the Modbus device (max. length = 30; “.” is not allowed).

Enable Data Collection: Enable or disable data collection for this Modbus device.
Communication Port: Select the communication interface of this Modbus device.
Unit ID: The unit ID of this Modbus device (options: 1 to 247).

IP Address: The IP Address of this Modbus device.

Port: The TCP port of this Modbus device (options: 0 to 65535).

Reconnect Delay: The delay time after the server tries to reconnect this Modbus device (options: 0 to
30000; default: 3000).

Reconnect Cycles: The maximum number of reconnect cycles (options: 0 to 10; default: 3).

Cycle Delay: The delay time after reaching the maximum number of reconnect cycles (options: 0 to 86400;
default: 3).

Polling Timeout: The timeout value when the server polls data from this Modbus device (options: 0 to
30000; default: 3000).

Polling Retries: The maximum number of retries after a polling timeout occurs (options: 0 to 10; default:

3).
: i Reconnect
Polling F;_[:!::Ipf Reconnect Cycle
| | | | |

Polling I Polling Recannectl Cycle
Timeout Timeout Delay Delay
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Serial Communication Port

If a serial communication port is selected, the Device Property configuration window will appear as shown

below:

Device Property

Device Name: Devicel Enable Data Collection

Communication Port: [CDMl ']

Protocol: Modbus/RTU protocol

Device Settings Timeout Settings
Unit ID: [1 vl Response Timeout: 3000 L=
|
Poling Delay: 10 ms

The following configuration items only appear when a serial communication port is selected.

¢ Response Timeout: The timeout value when the server polls the data of this Modbus device (options: 0 to

30000; default: 3000).

¢ Polling Delay: The delay time after a polling timeout occurs (0 to 60000; default: 10).

The newly created device group will now be shown as belonging to this group.

Hle Edit View Iools Buntime Help

e R T O

KL

IEEOASD R A B
-l Active Device List Device Name Enabled
B E2242-01 (00:90:e8: 16:€7:15) n
=+ Modbus Device Group List Dewced e
=8 ] Device2 Yes
B Device1
il - [} Device2

Editing a Modbus Device

Communication Port

Intel(R) 82577LM Gigabit ...
comM1

Pratocol

Modbus/TCP protocol
Modbus/RTU protocol

Un)

Right click the Modbus device you would like to edit and then click Properties... in the popup menu, or click the
Modbus device to select it and then click the Properties icon in the Quick Launch toolbar to open the properties

configuration window.

File Edit View Tools Runtime Help

nEmnds @i e

SE ]: Active Device List Tag Group
- ¥ E2242-01 (00:90:28:16:7:15)
=- ]1 Modbus Device Group List
= DeviceGroup1
)
B Device Mew Tag Group
Move to Device Group *
Paste Ctrl+V
Delete Ctrl+D

Impaort Device Tags (.csv)...
Export Device Tags (.csv)...

1T

Properties...

NOTE

You are not allowed to cut, copy, or paste a Modbus device.

www.ipc2u.ru
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Deleting a Modbus Device

Right click the Modbus device and then click Delete in the popup menu, or click the Modbus device to select it
and then click the Delete icon in the Quick Launch toolbar.

— .

File Edit View Tools Runtime Help

¥ n
| |
=44 Active Device List Tag Group Tag Mame
¢ e ) E2242-01(00:90:e8:16:e7:15)
=4 Modbus Device Group List
-l DeviceGroupl
-

- ) Device2 Mew Tag Group
Move to Device Group 2
Paste Ctrl+V
Delete Ctrl+D

Import Device Tags (csv)...
Export Device Tags (.csv)...

Properties...

Date Ti

Moving a Modbus Device to a Different Device Group

1. Right click the Modbus device and then click the target device group in the popup menu.

- ;
E) MX-AOPC UA Server

File Edit \Miew Tools Runtime Help

inl BT ls&@&‘%ﬁ%ﬁ@\ﬂﬂ\

gl Active Device List Tag Group Tag Name
.- l E2242-01 (00:90:e8: 16:27: 15)

=4 Modbus Device Group List
DeviceGroupl

= | DeviceGrou

Mew Tag Group i

Movwe ta Device Group » DeviceGroupl

Paste Ctrl+V DeviceGeoup’

Delete Ctrl+D

Import Device Tags (.csv)...

L

Export Device Tags (.csv)...

Properties...
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2. The Modbus device will be moved to the target device group.

&N

B MX-AOPC UA Ser

File Edit \iew Tools Runtime Help

S EILY S

E“l Active Device List

-/ Modbus Device Group List
E|i] DeviceGroupl
- B Devicel

=& DeviceGroup2

-
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Tag Management

The following topics are covered in this chapter:

O Tag Groups
» Adding a Tag Group to a Device
Editing a Tag Group
Cutting a Tag Group
Copying a Tag Group
Pasting a Tag Group

YV V V VYV V

Deleting a Tag Group
O Modbus Tags
» Adding a Modbus Tag to a Tag Group
» Importing a List of Modbus Tags into a Modbus Device
» Editing a Modbus Tag
» Deleting a Modbus Tag
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Tag Groups

In this section we explain how to use the configuration console to add, edit, cut, copy, paste, and delete tag
groups.

Adding a Tag Group to a Device

1. Rightclick the device that the tag group will be added to and then click New Tag Group in the popup menu,
or click the device to select it and then click the New Tag Group icon on the Quick Launch toolbar.

v R

File Edit \iew Tools Runtime Help
e wnaER & 4B
S| e
=4 Active Device List Tag Group
. = ) E2242-01 (00:90:e8:16:27:15)
=+ Modbus Device Group List

=~y DeviceGroup1

' R Devicel

Mew Tag Group

Move to Device Group k

Paste Ctrl+V
Delete Ctrl+Dr

Import Device Tags (.csv)...

Export Device Tags (.csv)...

Properties...
Date

w o

2. Type in the name of the tag group (max. length = 30 characters; “.” is not allowed) and then click OK.

Tag Group PropertyA

Tag Group Mame:

[ ok || cancl

3. The new tag group will be added to the device.

o S

File Edit \iew Tools Runtime Help

—— . ] - —
NMEENdsD
E|!i Active Device List Tag!
i Lo ) E2242-01 (D0:90:e8:15:27: 15)
-/ Modbus Device Group List
=& DeviceGroupi
= | Devicel

" o
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Editing a Tag Group

Right click the tag group and then click Properties in the popup menu, or click the tag group to select it and
then click the Properties icon on the Quick Launch toolbar.

File Edit \iew Tools Runtime Help

— e 1 e
w00 .0 & B[R] X
EHAOAS
E|li Active Device List Tag Mame
to ) E2242-01 (00:90:28: 16:27: 15)

Elli Modbus Device Group List
=& DeviceGroupl

= l Devicel
Mew Tag
Cut Ctrl+X
Cl::lp}" Ctrl+C
Delete Del
Properties —

Cutting a Tag Group

Right click the tag group and click Cut in the popup menu, or click the tag group to select it and then click the
Cut icon on the Quick Launch toolbar.

F S
oo

Eile Edit \iew Tools Runtime Help

e pr———n — 1 o [
Fadss
DNEmENOdsS
Elli Active Device List Tag Name
P e B E2242-01 (D0:90:e8: 16:27: 15)
=+ Modbus Device Group List
=I-E ) DeviceGroup1

(= ] Devicel
Mew Tag
Cut Ctrl+X
Copy Ctrl+C
Delete Del
Properties
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Copying a Tag Group

Right click the tag group and then click Copy in the popup menu, or click the tag group to select it and then
click the Copy icon on the Quick Launch toolbar.

PrEcvess

Eile Edit \iew Tools Runtime Help

L
=g ‘Ii Active Device List Tag Mame Tag Tyr
N e l E2242-01 (00:90:28: 16:27:15)
=8 Jli Modbus Device Group List
=- i] DeviceGroupl
=~ ) Devicel
-
Mew Tag
Cut Ctrl+X
Copy Ctrl+C
Delete Del
Properties
1|

Pasting a Tag Group

Right click the Tag Group and then click Paste in the popup menu, or click the tag group to select it and then
click the Paste icon on the Quick Launch toolbar.

(IEcovess

FEile Edit Wiew Tools Runtime Help
T EN 1R

El JI Artive Device List Tag Group Tag Name
- ‘B E2242-01 (00:90:e8: 16:27: 15)
=- JI Modbus Device Group List
=k _] DeviceGroupl
EI . Devicel
i i TagGroupl
-
Mew Tag Group
Meowe to Device Group 2
Paste Ctrl+W
Delete Ctrl+D
Import Device Tags (.csv)... m
Export Device Tags (.csv)...
Date 1 P gs ( )
Properties...
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Deleting a Tag Group

Right click the tag group and then click Delete in the popup menu, or click the tag group to select it and
then click the Delete icon on the Quick Launch toolbar.

Proeeress

File Edit View Tools Runtime Help

—— . e 1 - i \ I .
NEEndsaKiAaB 8
=14 Active Device List Tag Name Tag Type
i b ) E2242-01 (D0:90:e8: 16:e7: 15)
-8 Modbus Device Group List
=-&) DeviceGroup1
E|l Device1

fares ﬁ-

Mew Tag

Cut Ctrl+X
Copy Ctrl+C
Delete Del
Properties

[ it L

Modbus Tags

In this section we explain how to use the configuration console to add, edit, delete, and move a Modbus tag.

Adding a Modbus Tag to a Tag Group

1. Right click the tag group that the Modbus tag will be added to and then click New Tag in the popup menu,
or click the tag group to select it and then click the New Tag icon on the Quick Launch toolbar.

File Edit View Tools Runtime Help

NMEEOds
El!i Active Device List Tag Mame
¢ b ) E2242-01 (00:90:28: 16:27:15)
-8 Modbus Device Group List
=-&) DeviceGroupl
E|l Devicel

g 720G oun

Mew Tag

Cut Ctrl+X
Copy Ctrl+C
Delete Del
Properties

=
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2. Edit the items in the Tag Property window as needed.

Teg erocery S

Tag Name: | LE:EE

Description:

Start Address: 0

Function Code: [Reaerite Coils (D) ']

Data Type: [Boolean V]

Access Right: Read/Write

[ OK ][ Cancel ]

Tag Name: The name of the Modbus tag (max. length = 30; “.” is not allowed).
Description: Description of this Modbus tag (max. length = 25).
Start Address: Define the start address of this Modbus tag (0 to 65535).

Function Code: Selecting the function code for this Modbus tag (options: 1: Read/Write Coils; 2: Read
Discrete Inputs; 3: Read Input Registers; 4: Read/Write Holding Registers).

vV V V VvV

> Data Type: Selecting the data type of this Modbus tag (options: Boolean; Unsigned short integer;
Unsigned integer; Float).

3. Click the tag group to verify that the Modbus tag was added to this group.
v s e R = ==

File Edit View Tools Runtime Help

P — Y DAY
[ W ER r 3

TEENdss& A5 89 8

E‘ " Active Device List Tag Name Tag Type Functin Code Start Address Data Type Access Rights Description

' E2242-01 (00:90:e8: 16:27: 15) = 2

21118 Modbus Device Group List % Tagl Poling 1 0000 Boolean Read-only

B i] DeviceGroup1
= | Devicel
" L TagGroupl '

Importing a List of Modbus Tags into a Modbus Device

To import a list of Modbus tags into a Modbus device, right click the Modbus device and then click Import
Device Tags (.csv) in the popup menu. Select a csv file on your PC to import the tags listed in the csv file into
the Modbus device. Refer to Chapter 3: Configuration Console > Menu Items - File for detailed csv file
formats.

File Edit View Tools Runtime Help

e aem o — & - | N

PNEENds& B

-1 Active Device List Tag Group

: 1 E2242-01 (00:90:e8: 16:27:15)

= ]: Modbus Device Group List

=& DeviceGroup1
' BDevicel

Mew Tag Group
Mowe to Device Group »
Pasts Cirl+V
Delete Ctrl+D
Import Device Tags (.csv)...
Export Device Tags [.csv)... [
Properties... —

Date Ti
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Editing a Modbus Tag

Click the Modbus tag to select it and then click the Properties icon on the Quick Launch toolbar.

File Edit View Tools Runtime Help

[=--{ 4 Modbus Device Group List
57 DeviceGroupl
Devicel

|| & TagGroupl

Deleting a Modbus Tag

Click the Modbus tag to select it and then click the Delete icon on the Quick Launch toolbar.

_— - = - \/ - .
iadsn 2RI L
PEENds N2 R . .
E‘ i Active Device List Tag Name Tag Type Functin Code Start Address Data Type Access Rights Description
E2242-01 (00:90:e8: 16:e7:15 -
( ) & Tagl Poliing 1 oo Boolean Read-only

File Edit View Tools Runtime Help . .
rErndssKieceluess s

Tag Type Start Address

=8 Active Device List Forctins Code:
B E2242-01(00:90:e8:16:7:15)

I (= Modbus Device Group List

-6 DeviceGroupl

£ ) Devicel

| o TagGroupl

Tag Mame
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Data Type

Rjreot lpoling 11 ______loow | Boolean ___| Read-only L

Access Rights Description
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6

License Registration and Activation

www.ipc2u.ru

Three versions of MX-AOPC UA Server are available. The trial version, which supports up to 30 connected
devices, can be installed and used for 30 days without registration. To use the free and paid versions you must
submit a license registration. Both free and paid versions can be used indefinitely, but the free version only
supports up to 30 connected devices. The three versions are summarized in the following table:

Version Connected Devices Run Time License File
Trial Up to 30 30 days Not Required
Free Up to 30 Unlimited Required
Paid Unlimited Unlimited Required

Take the following steps to register a license.

Step 1:

Get the PC User Code from the MX-AOPC UA server’s configuration console by clicking Help > License. For the
paid version, you will need to purchase a registration code from your Moxa distributor. The Registration Code
can be found on the product label.

User Code | rMOXA@ R

MN: MX-AOPC UA Server

User Code: 1613EB128766
ecasasnc IV

License Status: Trial Version
Rev: 1.00

Time Remaining: 11 days i ggdagilg‘;rggggq

egistration Coce: [| Il N1 HINNNI
[ TZAD010000001231

Step 2:
Go to Moxa’s Software Licensing website (http://license.moxa.com) and log in with your Moxa account and
password, or apply for an account if this is your first visit to the site.

Step 3:

On the Software Licensing website, navigate to Activate Your Software -> Software Package > MX-AOPC
UA Server. Select Free Version and enter the User Code, or select Paid Version and enter both the User
Code and Registration Code.

Home > Activate Your Software > Software Fackage =

MX-AOPC UA Server

*  Free Version
User Code:
Paid Version
Registration Code:
User Code:

Submit

www.moxa.pro
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Step 4:

Download the license file to a folder on your PC and unzip it.

Step 5:

From MX-AOPC UA server’s configuration console, click Help > Licensing > Add License File to add the
license file (.lic) to MX-AOPC UA Server.

El MX-AOPC UA Se

File Edit View Tools PRuntime |Eep

— — —
LHS B .
S Y Active Device List

[/ Modbus Device Group List

Step 6:

TR

Server Help
Licensing
About...

License Info

Add License File

After license activation is complete, go to Help - License Info to check the current license status.

saiecre

g User Code

ih Complete license activation.

L e

User Code: 1613EB128766

License Status: Free Version

Max. Device Count: 30

User Code:

License Status:

1613EB128766

Paid Version
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Appendix

Port Usage

Port Type Usage

508 TCP Modbus Communication
53192 TCP Default UA Server Endpoint
9500 TCP Active OPC Server protocol
9900 TCP Active OPC Server protocol

Configuring DCOM Settings

If the OPC client only supports the OPC Data Access (DA) standard, you will need to configure DCOM settings.

Before launching MX-AOPC UA Server,

configure the DCOM settings for your security policy.

NOTE

If the OPC Client and Server software are installed on different servers, the DCOM, WORKGROUP, System

Account, and Password settings should be the same.

1.

Go to the START menu and type dcomcenfg to activate the Component Services dialog box.

- See more results

| clccmcnfg|

x | | Shut down | » |

& ]

fre"|

2. Right click My Computer under Console Root > Component Services > Computers, and click
Properties to open the My Computer Properties dialog box.

o :
#= Component Services

2. File

ol AN :

Action View Window

Help

a= 1
o=
o= |

(3 Conszole Root
4 % Component Services
. ] Computers
. E Event Yiewer (Local)
5 Services (Local)

IXE | L IEE

A

ﬂ_ Refresh all components

View

Prupﬁes

www.ipc2u.ru
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3. Click the COM Security tab and edit who is allowed by default to access, launch, or activate the

applications or objects.

: My Computer Properties E

General | Options | Default Properties
Defeult Protocols | COM Security |  MSDTC

Aocess Pemmizsions

You may edt who is allowed default access to applications. You may
also set limits on applications that detemine their own pemissions.

& Caution: Modifying access pemissions can affect the abilty
i [E of applications to start, connect, function and./or un
securehy.

| Edtlimts.. | | EdtDefaut.. |

L

Launch and Activation Pemissions

You may edt who is allowed by default to launch applications or
activate objects. You may also set limits on applications that
determine their own pemissions.

& Caution: Modifying launch and activation permissions can
affect the ability of applications to start, connect, function
and/ar run securchy.

| Edtlimts.. | | EdtDefaut..

Leam more about setting these properties.

QK ] [ Cancel Apply
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4. Add Everyone, INTERACTIVE, NETWORK, and SYSTEM, and set Allow permission to all of these

groups.

Access Permissicn

Default Security

|SI'DLID Or user names:

82 Everyone
8% INTERACTIVE
8% NETWORK
82 5YSTEM
’ Add... ] ’ Remave ]
Pemigsions for NETWORK Allow Deny
Local Access =
Remote Access [

Leam about access control and permissions

[ OKDCH Cancel |

e

Launch and Activation Permiszicn

Default Security

R

GI‘CILID Or User names:

82 Everyone

82 SYSTEM

8% INTERACTIVE
82 NETWORK

Pemissions for Everyone

Add... ][ Remove ]

Allow Deny

Local Launch
Remote Launch
Local Activation
Remote Activation

ENE s s

Leam about access control and permissions

[ ok QJ[ Cancel

www.moxa.pro
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5. Click the Default Properties tab and check if the settings are the same as shown in the screenshot below.

6.

My Computer Properties

7 ]Sl

Default Protocols |  COMSecuty | MSDTC

General | Options | Default Properties

[#]iEnable Digtributed COM on this computer:

[ Enable COM Intemat Services on this computer
Default Distributed COM Communication Properties
The Authertication Level specifies securty at the packet level.

Default Authentication Level:

Connect -

The impersanation level specfies whether applications can determine
who is calling them, and whether the application can do operations
using the cliert’s idertity.

Default Impersonation Lewvel:
(dentiy -

Securty for reference tracking can be provided f authentication is used
and that the default impersanation level is not anomymous.

[] Provide additional security for reference tracking

Leam mare about getting these properties.

[ oK EF][ Cancel | [ Apply

=1

Click Yes when the following warning message appears.

DCOM Machine wide settings

You are about to modify machine wide DCOM settings, this will effect

_J; all the applications on the maching, seme applications may not work

correctly as a result.Update DCOM settings?

Mo

[yl
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7. Go back to the Component Services dialog box, and right click MOXA_ACTIVE_OPC_SERVER under
Console Root > Component Services > Computers > My Computer > DCOM Config, and then click

8.

Properties.

. Component Services

%. File Action View Window Help

95| nEXECHE D

b Microsoft Windows WSMan Provi «

Microsoft Windows W5Man Provi
Microsoft WMI Provider Subsyste
Microsoft WMWI Provider Subsyste
MMC Application Class

'MOXA_ACTIVE_OPC_SERVER|

MSDAINITIALIZE View
IMsRdpSessicniManager

MSTTS DecOhj Class Surrog
MNAP Agent Service Properties h
Nap Elevated COM class
NCLUA L

Mew Window from Here

> 0 W W W e II\:S.I.EIB LEL LR

LINEADT [

Click the General tab, and set the Authentication Level to Connect.

r-

General | Location I Security | Endpoints I Ident'rt)'|

MOXA_ACTIVE_OPC_SERVER Properties [ % |[=E3m]

General properties of this DCOM application
Application Name:  MOXA_ACTIVE_QOPC_SERVER
Application 1D {BcbfEabi-1bad-4aZb-0b92-554d294 375 5]

Application Type: Local Server

Authentication Level: |Connect

T

Leam more about setting these properties.

Local Path: C:%Program Files"Mooa Active OPChServer\ ACT

oK ﬂ[ Cancel ][ Loply ]

www.moxa.pro



9. Click the Security tab. You may either apply the default settings of Access, Launch, and Activation
Permissions to the Active OPC Server or customize the permission settings. If you would like to customize
the settings, make sure that Everyone, INTERACTIVE, NETWORK, and SYSTEM are added, and the
permission for these groups is set to Allow.

MOXA_ACTIVE_OPC_SERVER Properties [~ 7| [mE3a]

| Genaral I Location | Securty | Endpoints I Idenﬁh"|

Launch and Activation Permissions

(@) Customize

Im

Aocess Permigsions
@ Use Default

(@) Customize

Configuration Permissions

() Use Defautt

Leam more about setting thess properties.

Coc ) Coms ) T

10. Click the Identity tab and make sure The interactive user is selected. If the MX-AOPC UA Server is
running as a Windows service, The system account is selected. Now DCOM is ready to accept all incoming
connections.

MOMNA_ACTIVE_OPC_SERVER Properties [~ B[]

| General | Location | Securty | Endpoints | Identiy |

Which user account do you want to use to un this application?

@ The interactive user.
() The launching user.

() This user.

Leam mare about setting these properties.

[ ok Ds“ Cancel | [ Apply |

www.ipc2u.ru WWW.moxa.pro
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